Slow Loading Times and Navigation Menu Items Not Loading

Incident Report for Cognota

Update

We are continuing to monitor for any further issues.
Posted Nov 19, 2025 - 17:53 UTC

Update

We’ve identified what we believe to be the root cause of the issue and a fix has been released. Our team is continuing to monitor system performance to ensure everything remains stable before confirming that the incident is fully resolved.
Posted Nov 18, 2025 - 15:01 UTC

Update

We identified a recurrence of the issue causing intermittent slow loading and missing navigation menu items. Mitigation steps have been applied, and performance has been stabilized.

Our team is continuing to monitor system stability and is investigating the underlying cause of this recurrence. We’ll provide an update once we have more information.
Posted Nov 10, 2025 - 15:22 UTC

Update

We are continuing to monitor for any further issues.
Posted Nov 07, 2025 - 21:20 UTC

Monitoring

Mitigation steps have been applied and performance has been stabilized.

Our team is continuing to monitor system stability and is investigating the underlying cause of this recurrence. We’ll provide an update once we have more information.
Posted Nov 04, 2025 - 16:25 UTC

Investigating

We are aware that some users are once again experiencing slow loading times and missing navigation menu items. Our team is actively investigating and will share updates as we know more.
Posted Nov 04, 2025 - 14:19 UTC

Update

We identified a recurrence of the issue causing intermittent slow loading and missing navigation menu items. Mitigation steps have been applied, and performance has been stabilized.

Our team is continuing to monitor system stability and is investigating the underlying cause of this recurrence. We’ll provide an update once we have more information.
Posted Oct 31, 2025 - 19:52 UTC

Update

We’ve identified what we believe to be the root cause of the issue. Our team is continuing to monitor system performance to ensure everything remains stable before confirming that the incident is fully resolved.
Posted Oct 31, 2025 - 16:10 UTC

Monitoring

Our team has applied mitigation measures to restore normal performance and is taking additional steps to maintain system stability. We are closely monitoring the platform to ensure continued stability. We appreciate your patience as we work toward a full resolution.
Posted Oct 28, 2025 - 20:10 UTC

Investigating

Our team is actively investigating and will share updates as we know more.
Posted Oct 28, 2025 - 18:51 UTC

Update

We are aware that some users are once again experiencing slow loading times and missing navigation menu items. Our team is actively investigating and will share updates as we know more.
Posted Oct 28, 2025 - 17:27 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 28, 2025 - 15:41 UTC

Monitoring

Our team implemented a potential fix, while taking additional steps to restore normal performance, and is closely monitoring the system to maintain stability. We appreciate your patience and understanding as we work to resolve this.
Posted Oct 27, 2025 - 18:55 UTC

Investigating

We are aware that some users are once again experiencing slow loading times and missing navigation menu items. Our engineering team is actively investigating the root cause of this recurring issue.

We are evaluating mitigation steps while we work toward a permanent resolution.
Posted Oct 27, 2025 - 17:27 UTC

Update

Early signs show the situation is improving, and we’re closely monitoring the platform to ensure stability.
Posted Oct 27, 2025 - 14:46 UTC

Identified

We are currently applying mitigation measures to restore normal performance while we continue to investigate the underlying issue.
Posted Oct 27, 2025 - 14:29 UTC

Investigating

We are currently investigating reports of slow loading times across the platform and navigation menu items failing to load. We will provide updates as we know more.
Posted Oct 27, 2025 - 14:08 UTC
This incident affects: Cognota App.